Back to overview
Degraded
Delayed email notifications due to AWS outage
Oct 20 at 07:42am UTC
Affected services
API
Resolved
Oct 20 at 09:34am UTC
Email deliveries are back to normal.
Affected services
Created
Oct 20 at 07:42am UTC
We are seeing elevated error rates in our email delivery service due to an ongoing AWS outage. As a result, some emails may be delayed.
Affected services